Компилятор плагинов CS 1.6 для AmxModX 1.9.0 [Amxx]



Компилятор плагинов AmxModX для CS 1.6. Полный набор. Внутри архива сразу есть так же популярные инклуды для плагинов.

Инструкция по работе:

1) Разархивировать архив.
2) Закинуть нужный исходник плагина формата .sma в папку с компилятором (не обязательно, можно и так).
3) Перенести исходник плагина (.sma) на ярлык с названием compile.
4) Откроется окно компиляции и после успешной компиляции Вы увидите фразы, типа: Done. Compilation Time: 0.5~ sec. Значит всё в порядке!
5) После этого в папке compiled появится Ваш скомпилированный плагин формата .amxx, который можно устанавливать на сервер.


Если при компиляции возникли фразы типа error и т.д., значит исходнику не хватает какого-то инклуда плагина для компиляции, плагин написан криво, либо просто он написан не для этой версии amxx (1.9.0), нужен компилятор другой версии. Приятной работы! ;)
 

Видеоинструкция





Категория: Модули | Добавил: Leo
Просмотров: 5730 | Загрузок: 2292 | Комментарии: 4 | Рейтинг: 3.0/2
Автор файла: | Источник: http://amxmodx.org


Всего комментариев: 4
0
3   [Материал]
Leo, А как насчет ошибки, где не хватает инклуда для плагина?) Ошибки нада читать, может быть массу причин.

0
4   [Материал]
Ну так если не хватает инклуда для плагина - это вопрос к автору плагина, где его взять. Я лишь для удобства добавил самые популярные. Обычно нужные инклуды для плагина идут вместе с ним.

0
1   [Материал]
не компилируется пишет ошибку

0
2   [Материал]
Ошибка не в компиляторе, а в плагине только может быть. Причин две: либо ошибка в коде плагина, либо ошибка в том, что плагин не совместим с версией 1.9.0 (нужен компилятор другой версии). Хотя, чаще всего - бывает именно 1-ая ошибка.

Имя *:
Email *:
Код *: